공룡호가 사는 세상 이야기

The Original : http://acm.uva.es/p/v1/100.html
UVA no : 100

영어로 되어있어서 어려운 건줄 알았더니..OTL.. 어쨌든 Accepted!!

>>Background
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

>>The Problem
Given the input 22, the following sequence of numbers will be printed
22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)
Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.
For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

>>The Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.
You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
You can assume that no opperation overflows a 32-bit integer.

>>The Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

>>Sample Input
1 10
100 200
201 210
900 1000

>>Sample Output
1 10 20
100 200 125
201 210 89
900 1000



#include <stdio.h>
#include <stdlib.h>

int solve(int first, int last)
{
int cnt, i = 0;
int max = 1;

for (first; first <= last; first++)
{
i = first;
while (i != 1)
{
if (i % 2 == 0) //even number
{
i = i / 2;
cnt++;
}

else //odd number
{
i = i * 3 + 1;
cnt++;
}
}
if (cnt > max) //MAX Update
max = cnt;
cnt = 0; //cnt Initialize
}
return max;
}

void main(void)
{
int i, j;
scanf("%d %d", &i, &j);

if(i < 1 || i > 10000000 || j < 1 || j > 10000000)
exit(1); //Error Check

int max = solve(i, j); //call solve function

printf("\n%d %d %d\n\n", i, j, max);
}

'프로그래밍' 카테고리의 다른 글

chaos in FOR loop  (0) 2006.01.13
ACM 10110 Light, More Light  (0) 2006.01.13
오각수 구하기  (0) 2006.01.10
Merge Sorting Algorithm.  (0) 2006.01.10
Distribution Counting(분포수 세기)  (0) 2006.01.09